package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`h+i+k+e+`)
var str = `I am looking for simple way to have catch variant of word like
hike hhike hiike hikke hikkee
Using something similar to the format below...
[([a-zA-Z]){4,}]
Thanks`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}