# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(SELECT\s+).*?(FROM.*)/\1 COUNT(*) \2/g;t' <<< "SELECT col1, col2 FROM my_table where...\"
SELECT * FROM my_table where...\"
"