import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(SELECT\\s+).*?(FROM.*)";
final String string = "SELECT col1, col2 FROM my_table where...\" \n"
+ "SELECT * FROM my_table where...\" \n\n";
final String subst = "\\1 COUNT(*) \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}