use strict;
my $str = 'SELECT col1, col2 FROM my_table where..."
SELECT * FROM my_table where..."
';
my $regex = qr/(SELECT\s+).*?(FROM.*)/p;
my $subst = '\\1 COUNT(*) \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";