package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(SELECT\s+).*?(FROM.*)`)
var str = `SELECT col1, col2 FROM my_table where..."
SELECT * FROM my_table where..."
`
var substitution = "\1 COUNT(*) \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}