#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(SELECT\s+).*?(FROM.*)"
Local $sString = "SELECT col1, col2 FROM my_table where..." " & @CRLF & _
"SELECT * FROM my_table where..." " & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1 COUNT(*) \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)