$re = '/(SELECT\s+).*?(FROM.*)/';
$str = 'SELECT col1, col2 FROM my_table where..."
SELECT * FROM my_table where..."
';
$subst = "\1 COUNT(*) \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;