import Foundation
let pattern = #"(SELECT\s+).*?(FROM.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SELECT col1, col2 FROM my_table where..."
SELECT * FROM my_table where..."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 COUNT(*) \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)