# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*?href\s*=\s*"[^>]*?blogspot\.com[^>]*>(<img[^>]*?\\/>)<\\/[^>]*>/$1/gmi;t' <<< "<a style=\"clear: left; float: left; margin-bottom: 1em; margin-right: 1em;\" href=\"http://3.bp.blogspot.com/xxxxxxx.JPG\"><img src=\"xxxxxxxxxxxxxx\" alt=\"\" width=\"200\" height=\"150\" border=\"0\" /></a>
"