const regex = /<[^>]*?href\s*=\s*"[^>]*?blogspot\.com[^>]*>(<img[^>]*?\/>)<\/[^>]*>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*?href\\s*=\\s*"[^>]*?blogspot\\.com[^>]*>(<img[^>]*?\\\/>)<\\\/[^>]*>', 'gmi')
const str = `<a style="clear: left; float: left; margin-bottom: 1em; margin-right: 1em;" href="http://3.bp.blogspot.com/xxxxxxx.JPG"><img src="xxxxxxxxxxxxxx" alt="" width="200" height="150" border="0" /></a>
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);