// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<[^>]*?href\s*=\s*"[^>]*?blogspot\.com[^>]*>(<img[^>]*?\/>)<\/[^>]*>"#).unwrap();
let string = "<a style=\"clear: left; float: left; margin-bottom: 1em; margin-right: 1em;\" href=\"http://3.bp.blogspot.com/xxxxxxx.JPG\"><img src=\"xxxxxxxxxxxxxx\" alt=\"\" width=\"200\" height=\"150\" border=\"0\" /></a>
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}