# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[^>]*?href\s*=\s*\"[^>]*?blogspot\.com[^>]*>(<img[^>]*?\/>)<\/[^>]*>"
test_str = ("<a style=\"clear: left; float: left; margin-bottom: 1em; margin-right: 1em;\" href=\"http://3.bp.blogspot.com/xxxxxxx.JPG\"><img src=\"xxxxxxxxxxxxxx\" alt=\"\" width=\"200\" height=\"150\" border=\"0\" /></a>\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.