package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<[^>]*?href\s*=\s*"[^>]*?blogspot\.com[^>]*>(<img[^>]*?\/>)<\/[^>]*>`)
var str = `<a style="clear: left; float: left; margin-bottom: 1em; margin-right: 1em;" href="http://3.bp.blogspot.com/xxxxxxx.JPG"><img src="xxxxxxxxxxxxxx" alt="" width="200" height="150" border="0" /></a>
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}