import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*?href\\s*=\\s*\"[^>]*?blogspot\\.com[^>]*>(<img[^>]*?\\/>)<\\/[^>]*>";
final String string = "<a style=\"clear: left; float: left; margin-bottom: 1em; margin-right: 1em;\" href=\"http://3.bp.blogspot.com/xxxxxxx.JPG\"><img src=\"xxxxxxxxxxxxxx\" alt=\"\" width=\"200\" height=\"150\" border=\"0\" /></a>\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}