using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*?href\s*=\s*""[^>]*?blogspot\.com[^>]*>(<img[^>]*?\/>)<\/[^>]*>";
string substitution = @"$1";
string input = @"<a style=""clear: left; float: left; margin-bottom: 1em; margin-right: 1em;"" href=""http://3.bp.blogspot.com/xxxxxxx.JPG""><img src=""xxxxxxxxxxxxxx"" alt="" width=""200"" height=""150"" border=""0"" /></a>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}