#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<div class="(data|plainText|extData)">\s*(.*?)\s*<\/div>"
Local $sString = "<div class="data">" & @CRLF & _
" Something" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div class="data">" & @CRLF & _
" Text in here" & @CRLF & _
" <a class="data" href="links"><img src="whatever.png"></a>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")