// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?s)<div class="(data|plainText|extData)">\s*(.*?)\s*<\/div>"#).unwrap();
let string = "<div class=\"data\">
Something
</div>
<div class=\"data\">
Text in here
<a class=\"data\" href=\"links\"><img src=\"whatever.png\"></a>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}