import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<div class=\"(data|plainText|extData)\">\\s*(.*?)\\s*<\\/div>";
final String string = "<div class=\"data\">\n"
+ " Something\n"
+ "</div>\n\n"
+ "<div class=\"data\">\n"
+ " Text in here\n"
+ " <a class=\"data\" href=\"links\"><img src=\"whatever.png\"></a>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}