$re = '/(?s)<div class="(data|plainText|extData)">\s*(.*?)\s*<\/div>/m';
$str = '<div class="data">
Something
</div>
<div class="data">
Text in here
<a class="data" href="links"><img src="whatever.png"></a>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);