const regex = /(?s)<div class="(data|plainText|extData)">\s*(.*?)\s*<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<div class="(data|plainText|extData)">\\s*(.*?)\\s*<\\\/div>', 'gm')
const str = `<div class="data">
Something
</div>
<div class="data">
Text in here
<a class="data" href="links"><img src="whatever.png"></a>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}