re = /(?s)<div class="(data|plainText|extData)">\s*(.*?)\s*<\/div>/m
str = '<div class="data">
Something
</div>
<div class="data">
Text in here
<a class="data" href="links"><img src="whatever.png"></a>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end