using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<div class=""(data|plainText|extData)"">\s*(.*?)\s*<\/div>";
string input = @"<div class=""data"">
Something
</div>
<div class=""data"">
Text in here
<a class=""data"" href=""links""><img src=""whatever.png""></a>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}