#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?'type'.*?) (?'name'.*)"
Local $sString = "QString CurrentVideoSource"
Local $sSubst = "Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)