import Foundation
let pattern = #"(?'type'.*?) (?'name'.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"QString CurrentVideoSource"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}