package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?'type'.*?) (?'name'.*)`)
var str = []byte(`QString CurrentVideoSource`)
var substitution = []byte("Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}