import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'type'.*?) (?'name'.*)";
final String string = "QString CurrentVideoSource";
final String subst = "Q_PROPERTY(\\{type} \\{name} READ \\{name} WRITE set\\{name} NOTIFY \\{name}Changed)\\n\\n\\{type} \\{name}() const\\n{ return m_\\{name}; }\\n\\nvoid set\\{name}(\\{type} \\{name})\\n{\\n\\tif(this->m_\\{name} != \\{name})\\n\\t{\\n\\t\\tthis->m_\\{name} = \\{name};\\n\\t\\temit \\{name}Changed();\\n\\t}\\n}\\n\\nvoid \\{name}Changed();\\n\\n\\{type} m_\\{name};";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}