const regex = /(?'type'.*?) (?'name'.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'type\'.*?) (?\'name\'.*)', '')
const str = `QString CurrentVideoSource`;
const subst = `Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);