using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'type'.*?) (?'name'.*)";
string substitution = @"Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};";
string input = @"QString CurrentVideoSource";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}