using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<=^[^:]+):";
string substitution = @"=";
string input = @"id : AA:BB:CC:DD:11:22
connectionStatus : CONNECTED
hostType : WIRELESS
authType : WPA2/WPA3+802.1x/FT-802.1x";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}