import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=^[^:]+):";
final String string = "id : AA:BB:CC:DD:11:22\n"
+ "connectionStatus : CONNECTED\n"
+ "hostType : WIRELESS\n"
+ "authType : WPA2/WPA3+802.1x/FT-802.1x";
final String subst = "=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}