import Foundation
let pattern = #"(?m)(?<=^[^:]+):"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
id : AA:BB:CC:DD:11:22
connectionStatus : CONNECTED
hostType : WIRELESS
authType : WPA2/WPA3+802.1x/FT-802.1x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"="#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)