$re = '/(?m)(?<=^[^:]+):/m';
$str = 'id : AA:BB:CC:DD:11:22
connectionStatus : CONNECTED
hostType : WIRELESS
authType : WPA2/WPA3+802.1x/FT-802.1x';
$subst = "=";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;