use strict;
my $str = 'id : AA:BB:CC:DD:11:22
connectionStatus : CONNECTED
hostType : WIRELESS
authType : WPA2/WPA3+802.1x/FT-802.1x';
my $regex = qr/(?m)(?<=^[^:]+):/mp;
my $subst = '=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";