# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+?(\d+\s?[а-я]+)\.$/$1/gm;t' <<< "товар номер один емкость 50 мл, упаковка 60 шт.
товар номер два упаковка 100 шт.
товар номер три 10шт."