import re
regex = re.compile(r"^.+?(\d+\s?[а-я]+)\.$", flags=re.MULTILINE)
test_str = ("товар номер один емкость 50 мл, упаковка 60 шт.\n"
"товар номер два упаковка 100 шт.\n"
"товар номер три 10шт.")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)