// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+?(\d+\s?[а-я]+)\.$").unwrap();
let string = "товар номер один емкость 50 мл, упаковка 60 шт.
товар номер два упаковка 100 шт.
товар номер три 10шт.";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}