package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+?(\d+\s?[а-я]+)\.$`)
var str = `товар номер один емкость 50 мл, упаковка 60 шт.
товар номер два упаковка 100 шт.
товар номер три 10шт.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}