#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.+?(\d+\s?[а-я]+)\.$"
Local $sString = "товар номер один емкость 50 мл, упаковка 60 шт." & @CRLF & _
"товар номер два упаковка 100 шт." & @CRLF & _
"товар номер три 10шт."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)