import Foundation
let pattern = #"^.+?(\d+\s?[а-я]+)\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
товар номер один емкость 50 мл, упаковка 60 шт.
товар номер два упаковка 100 шт.
товар номер три 10шт.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)