$re = '/^.+?(\d+\s?[а-я]+)\.$/m';
$str = 'товар номер один емкость 50 мл, упаковка 60 шт.
товар номер два упаковка 100 шт.
товар номер три 10шт.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;