#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
"(?<blanks>[[:blank:]]+)" & @CRLF & _
"(?<var>"?[[:alnum:]_]+"?)" & @CRLF & _
"(?<csvar>("?[[:alnum:]_]+"?,?)+)" & @CRLF & _
")" & @CRLF & _
"^" & @CRLF & _
"(?&blanks)((?&var))" & @CRLF & _
"(?&blanks)((?&var))" & @CRLF & _
"(?&blanks)((?&csvar))" & @CRLF & _
""
Local $sString = " foo foo_123bar foo,bar,bazz" & @CRLF & _
" foo2 foo_456bar foo2,bar2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")