using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>""?[[:alnum:]_]+""?)
(?<csvar>(""?[[:alnum:]_]+""?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
";
string input = @" foo foo_123bar foo,bar,bazz
foo2 foo_456bar foo2,bar2";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}