import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ "(?<blanks>[[:blank:]]+)\n"
+ "(?<var>\"?[[:alnum:]_]+\"?)\n"
+ "(?<csvar>(\"?[[:alnum:]_]+\"?,?)+)\n"
+ ")\n"
+ "^\n"
+ "(?&blanks)((?&var))\n"
+ "(?&blanks)((?&var))\n"
+ "(?&blanks)((?&csvar))\n";
final String string = " foo foo_123bar foo,bar,bazz\n"
+ " foo2 foo_456bar foo2,bar2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}