// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>"?[[:alnum:]_]+"?)
(?<csvar>("?[[:alnum:]_]+"?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
"#).unwrap();
let string = " foo foo_123bar foo,bar,bazz
foo2 foo_456bar foo2,bar2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}