package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>"?[[:alnum:]_]+"?)
(?<csvar>("?[[:alnum:]_]+"?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
`)
var str = ` foo foo_123bar foo,bar,bazz
foo2 foo_456bar foo2,bar2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}