const regex = /(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>"?[[:alnum:]_]+"?)
(?<csvar>("?[[:alnum:]_]+"?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>"?[[:alnum:]_]+"?)
(?<csvar>("?[[:alnum:]_]+"?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
', 'gm')
const str = ` foo foo_123bar foo,bar,bazz
foo2 foo_456bar foo2,bar2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}