re = /(?(DEFINE)
(?<blanks>[[:blank:]]+)
(?<var>"?[[:alnum:]_]+"?)
(?<csvar>("?[[:alnum:]_]+"?,?)+)
)
^
(?&blanks)((?&var))
(?&blanks)((?&var))
(?&blanks)((?&csvar))
/mx
str = ' foo foo_123bar foo,bar,bazz
foo2 foo_456bar foo2,bar2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end