#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))"
Local $sString = "# Caught Stealing from Something (Warning) (3300-3599)" & @CRLF & _
"...(test)..., ...(Next)..., ...(Warning)... and so on" & @CRLF & _
"# this is a commented line (really)" & @CRLF & _
"This is not a commented like" & @CRLF & _
"This line has (items you are interested in) ok" & @CRLF & _
"This like has (multiple) (items)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")