using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))";
string input = @"# Caught Stealing from Something (Warning) (3300-3599)
...(test)..., ...(Next)..., ...(Warning)... and so on
# this is a commented line (really)
This is not a commented like
This line has (items you are interested in) ok
This like has (multiple) (items)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}