$re = '/\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))/m';
$str = '# Caught Stealing from Something (Warning) (3300-3599)
...(test)..., ...(Next)..., ...(Warning)... and so on
# this is a commented line (really)
This is not a commented like
This line has (items you are interested in) ok
This like has (multiple) (items)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);